Site slowness in Perform
Incident Report for Unified Talent
Resolved
This incident has been resolved
Posted Oct 14, 2021 - 07:56 PDT
Identified
The issue has been identified and we are working on a fix
Posted Oct 14, 2021 - 06:03 PDT
Investigating
Perform site may have intermittent loading and performance issues. This is impacting log ins at this time. We are currently investigating this issue.
Posted Oct 13, 2021 - 06:40 PDT
This incident affected: Unified Talent - US (Perform).