Widespread Outages
Incident Report for Unified Talent
Resolved
We have resolved this issue. If you experience future issues, please reach out to support.
Posted Oct 14, 2021 - 11:38 PDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2021 - 07:08 PDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2021 - 07:07 PDT
Investigating
We have received multiple reports of districts being unable to reach Records and Perform sites.

The error may be resolved by clearing your browser cache.

We are currently investigating and will update this page as more information becomes available.
Posted Oct 14, 2021 - 06:57 PDT
This incident affected: Unified Talent - US (Applicant Tracking, Employee Records, Perform).