Talent Service Disruption
Incident Report for Unified Talent
Resolved
This incident has been resolved.
Posted Apr 13, 2020 - 08:28 PDT
Monitoring
We are currently monitoring this situation. The workaround is still applicable at this time.
Posted Apr 10, 2020 - 12:21 PDT
Investigating
We are aware that some customers using Unified Talent Products, may currently be experiencing a service interruption in which some users are encountering a 404 error. As a temporary workaround, you can proceed as expected by clearing your browser cache or logging in through another web browser. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted Apr 10, 2020 - 09:13 PDT
This incident affected: Unified Talent - US (Applicant Tracking, Employee Records, Perform) and Unified Talent - Canada (Applicant Tracking, Employee Records, Perform).